Denial of service in Vim



Published: 2022-09-11
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-3153
CWE-ID CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Vim
Client/Desktop applications / Office applications

Vendor

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) NULL pointer dereference

EUVDB-ID: #VU67160

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2022-3153

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error within the vim_regcomp() function in regexp.c. A remote attacker can perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Vim: before 9.0.0404


CPE2.3 External links

http://huntr.dev/bounties/68331124-620d-48bc-a8fa-cd947b26270a
http://github.com/vim/vim/commit/1540d334a04d874c2aa9d26b82dbbcd4bc5a78de

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###