Multiple vulnerabilities in D-Link DIR-2150



Published: 2022-09-16
Risk Medium
Patch available YES
Number of vulnerabilities 5
CVE-ID CVE-2022-40720
CVE-2022-40717
CVE-2022-40718
CVE-2022-3210
CVE-2022-40719
CWE-ID CWE-77
CWE-121
Exploitation vector Local network
Public exploit N/A
Vulnerable software
Subscribe
DIR-2150
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor D-Link

Security Bulletin

This security bulletin contains information about 5 vulnerabilities.

1) Command Injection

EUVDB-ID: #VU67420

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-40720

CWE-ID: CWE-77 - Improper Neutralization of Special Elements used in a Command ('Command Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary commands on the target system.

The vulnerability exists due to improper input validation within the Dreambox plugin for the xupnpd service. A remote attacker on the local network can pass specially crafted data to the application and execute arbitrary commands on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

DIR-2150: 4.01


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-22-1224/
http://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10304

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Stack-based buffer overflow

EUVDB-ID: #VU67424

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-40717

CWE-ID: CWE-121 - Stack-based Buffer Overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error within the anweb service. A remote unauthenticated attacker on the local network can trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

DIR-2150: 4.01


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-22-1220/
http://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10304

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Stack-based buffer overflow

EUVDB-ID: #VU67423

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-40718

CWE-ID: CWE-121 - Stack-based Buffer Overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error within the anweb service. A remote attacker on the local network can trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

DIR-2150: 4.01


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-22-1221/
http://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10304

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Command Injection

EUVDB-ID: #VU67422

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-3210

CWE-ID: CWE-77 - Improper Neutralization of Special Elements used in a Command ('Command Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary commands on the target system.

The vulnerability exists due to improper input validation within the xupnpd service. A remote attacker on the local network can pass specially crafted data to the application and execute arbitrary commands on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

DIR-2150: 4.01


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-22-1222/
http://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10304

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

5) Command Injection

EUVDB-ID: #VU67421

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-40719

CWE-ID: CWE-77 - Improper Neutralization of Special Elements used in a Command ('Command Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary commands on the target system.

The vulnerability exists due to improper input validation within the xupnpd_generic.lua plugin for the xupnpd service. A remote attacker on the local network can pass specially crafted data to the application and execute arbitrary commands on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

DIR-2150: 4.01


CPE2.3 External links

http://www.zerodayinitiative.com/advisories/ZDI-22-1223/
http://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10304

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###