Denial of service in Ghostscript



Published: 2022-09-20
Risk Medium
Patch available NO
Number of vulnerabilities 1
CVE-ID CVE-2022-2085
CWE-ID CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Ghostscript
Universal components / Libraries / Libraries used by multiple products

Vendor Artifex Software, Inc.

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) NULL pointer dereference

EUVDB-ID: #VU67507

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-2085

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF file and perform a denial of service (DoS) attack.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Ghostscript: 9.00 - 9.55.0


CPE2.3 External links

http://bugs.ghostscript.com/show_bug.cgi?id=704945
http://git.ghostscript.com/?p=ghostpdl.git;h=ae1061d948d88667bdf51d47d918c4684d0f67df
http://bugzilla.redhat.com/show_bug.cgi?id=2095261
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ERSZX5LKDWAHZWJYBMP2E2UHOPUCDEGV/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###