Denial of service in Lighttpd



Published: 2022-09-29 | Updated: 2022-10-11
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-30780
CWE-ID CWE-400
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
lighttpd
Server applications / Web servers

Vendor lighttpd

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Resource exhaustion

EUVDB-ID: #VU67732

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-30780

CWE-ID: CWE-400 - Resource exhaustion

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources within the connection_read_header_more() function in connections.c. A remote attacker can trigger resource exhaustion by sending multiple requests with large HTTP headers and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

lighttpd: 1.4.56 - 1.4.58


CPE2.3 External links

http://redmine.lighttpd.net/issues/3059
http://podalirius.net/en/cves/2022-30780/
http://github.com/p0dalirius/CVE-2022-30780-lighttpd-denial-of-service

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###