Information disclosure in ruby-mysql



Published: 2022-10-03
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-3779
CWE-ID CWE-610
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
ruby-mysql
Universal components / Libraries / Programming Languages & Components

Vendor TOMITA Masahiro

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Externally Controlled Reference to a Resource in Another Sphere

EUVDB-ID: #VU67809

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-3779

CWE-ID: CWE-610 - Externally Controlled Reference to a Resource in Another Sphere

Exploit availability: No

Description

The vulnerability allows a remote attacker to obtain sensitive information.

The vulnerability exists due to missing authorization when working with local files on the system with installed ruby-mysql client. A malicious MySQL server can request content of an arbitrary local file on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

ruby-mysql: 2.9.5 - 2.9.14


CPE2.3 External links

http://www.rapid7.com/blog/post/2022/06/28/cve-2021-3779-ruby-mysql-gem-client-file-read-fixed/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###