SUSE update for ImageMagick



Published: 2022-10-10
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-3574
CWE-ID CWE-401
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
SUSE Linux Enterprise Storage
Operating systems & Components / Operating system

SUSE Manager Retail Branch Server
Operating systems & Components / Operating system

SUSE Linux Enterprise Desktop
Operating systems & Components / Operating system

openSUSE Leap
Operating systems & Components / Operating system

SUSE Manager Server
Operating systems & Components / Operating system

SUSE Manager Proxy
Operating systems & Components / Operating system

SUSE Linux Enterprise Server for SAP Applications
Operating systems & Components / Operating system

SUSE Linux Enterprise Server
Operating systems & Components / Operating system

SUSE Linux Enterprise High Performance Computing
Operating systems & Components / Operating system

SUSE Linux Enterprise Module for Development Tools
Operating systems & Components / Operating system

SUSE Linux Enterprise Module for Desktop Applications
Operating systems & Components / Operating system

ImageMagick-doc
Operating systems & Components / Operating system package or component

libMagick++-devel-32bit
Operating systems & Components / Operating system package or component

ImageMagick-devel-32bit
Operating systems & Components / Operating system package or component

perl-PerlMagick-debuginfo
Operating systems & Components / Operating system package or component

perl-PerlMagick
Operating systems & Components / Operating system package or component

libMagick++-devel
Operating systems & Components / Operating system package or component

ImageMagick-extra-debuginfo
Operating systems & Components / Operating system package or component

ImageMagick-extra
Operating systems & Components / Operating system package or component

ImageMagick-devel
Operating systems & Components / Operating system package or component

ImageMagick-debugsource
Operating systems & Components / Operating system package or component

ImageMagick-debuginfo
Operating systems & Components / Operating system package or component

ImageMagick-config-7-upstream
Operating systems & Components / Operating system package or component

ImageMagick-config-7-SUSE
Operating systems & Components / Operating system package or component

ImageMagick
Operating systems & Components / Operating system package or component

libMagickWand-7_Q16HDRI6-32bit-debuginfo
Operating systems & Components / Operating system package or component

libMagickWand-7_Q16HDRI6-32bit
Operating systems & Components / Operating system package or component

libMagickCore-7_Q16HDRI6-32bit-debuginfo
Operating systems & Components / Operating system package or component

libMagickCore-7_Q16HDRI6-32bit
Operating systems & Components / Operating system package or component

libMagick++-7_Q16HDRI4-32bit-debuginfo
Operating systems & Components / Operating system package or component

libMagick++-7_Q16HDRI4-32bit
Operating systems & Components / Operating system package or component

libMagickWand-7_Q16HDRI6-debuginfo
Operating systems & Components / Operating system package or component

libMagickWand-7_Q16HDRI6
Operating systems & Components / Operating system package or component

libMagickCore-7_Q16HDRI6-debuginfo
Operating systems & Components / Operating system package or component

libMagickCore-7_Q16HDRI6
Operating systems & Components / Operating system package or component

libMagick++-7_Q16HDRI4-debuginfo
Operating systems & Components / Operating system package or component

libMagick++-7_Q16HDRI4
Operating systems & Components / Operating system package or component

Vendor SuSE

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Memory leak

EUVDB-ID: #VU68074

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-3574

CWE-ID: CWE-401 - Improper Release of Memory Before Removing Last Reference ('Memory Leak')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform DoS attack on the target system.

The vulnerability exists due memory leak when executing a crafted file with the convert command. A remote attacker can force the application to leak memory and perform denial of service attack.

Mitigation

Update the affected package ImageMagick to the latest version.

Vulnerable software versions

SUSE Linux Enterprise Storage: 7.1

SUSE Manager Retail Branch Server: 4.2

SUSE Linux Enterprise Desktop: 15-SP3

openSUSE Leap: 15.3 - 15.4

SUSE Manager Server: 4.2

SUSE Manager Proxy: 4.2

SUSE Linux Enterprise Server for SAP Applications: 15-SP3

SUSE Linux Enterprise Server: 15-SP3

SUSE Linux Enterprise High Performance Computing: 15-SP3

SUSE Linux Enterprise Module for Development Tools: 15-SP3

SUSE Linux Enterprise Module for Desktop Applications: 15-SP3

ImageMagick-doc: before 7.0.7.34-150200.10.39.1

libMagick++-devel-32bit: before 7.0.7.34-150200.10.39.1

ImageMagick-devel-32bit: before 7.0.7.34-150200.10.39.1

perl-PerlMagick-debuginfo: before 7.0.7.34-150200.10.39.1

perl-PerlMagick: before 7.0.7.34-150200.10.39.1

libMagick++-devel: before 7.0.7.34-150200.10.39.1

ImageMagick-extra-debuginfo: before 7.0.7.34-150200.10.39.1

ImageMagick-extra: before 7.0.7.34-150200.10.39.1

ImageMagick-devel: before 7.0.7.34-150200.10.39.1

ImageMagick-debugsource: before 7.0.7.34-150200.10.39.1

ImageMagick-debuginfo: before 7.0.7.34-150200.10.39.1

ImageMagick-config-7-upstream: before 7.0.7.34-150200.10.39.1

ImageMagick-config-7-SUSE: before 7.0.7.34-150200.10.39.1

ImageMagick: before 7.0.7.34-150200.10.39.1

libMagickWand-7_Q16HDRI6-32bit-debuginfo: before 7.0.7.34-150200.10.39.1

libMagickWand-7_Q16HDRI6-32bit: before 7.0.7.34-150200.10.39.1

libMagickCore-7_Q16HDRI6-32bit-debuginfo: before 7.0.7.34-150200.10.39.1

libMagickCore-7_Q16HDRI6-32bit: before 7.0.7.34-150200.10.39.1

libMagick++-7_Q16HDRI4-32bit-debuginfo: before 7.0.7.34-150200.10.39.1

libMagick++-7_Q16HDRI4-32bit: before 7.0.7.34-150200.10.39.1

libMagickWand-7_Q16HDRI6-debuginfo: before 7.0.7.34-150200.10.39.1

libMagickWand-7_Q16HDRI6: before 7.0.7.34-150200.10.39.1

libMagickCore-7_Q16HDRI6-debuginfo: before 7.0.7.34-150200.10.39.1

libMagickCore-7_Q16HDRI6: before 7.0.7.34-150200.10.39.1

libMagick++-7_Q16HDRI4-debuginfo: before 7.0.7.34-150200.10.39.1

libMagick++-7_Q16HDRI4: before 7.0.7.34-150200.10.39.1


CPE2.3 External links

http://www.suse.com/support/update/announcement/2022/suse-su-20223552-1/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###