Improper Certificate Validation in Siemens Industrial Edge Management



Published: 2022-10-11
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-40147
CWE-ID CWE-295
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Industrial Edge Management
Server applications / SCADA systems

Vendor

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper Certificate Validation

EUVDB-ID: #VU68123

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-40147

CWE-ID: CWE-295 - Improper Certificate Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to a lack of validation of the server certificate when initiating a TLS connection. A remote attacker can perform a man-in-the-middle (MitM) attack and spoof a trusted entity.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Industrial Edge Management: before 1.5.1


CPE2.3
External links

http://cert-portal.siemens.com/productcert/pdf/ssa-649853.pdf

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###