Denial of service in unzip



Published: 2022-10-13
Risk Medium
Patch available NO
Number of vulnerabilities 1
CVE-ID CVE-2021-4217
CWE-ID CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
UnZip
Client/Desktop applications / Software for archiving

Vendor Info-ZIP

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) NULL pointer dereference

EUVDB-ID: #VU68298

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-4217

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error in unzip when handling Unicode strings. A remote attacker can trick the victim to open a specially crafted archive and perform a denial of service (DoS) attack.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

UnZip: 5.2 - 6.10c22


CPE2.3 External links

http://bugs.launchpad.net/ubuntu/+source/unzip/+bug/1957077
http://bugzilla.redhat.com/show_bug.cgi?id=2044583
http://access.redhat.com/security/cve/CVE-2021-4217

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###