Information disclosure in Openshift assisted-installer



Published: 2022-10-31
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-3684
CWE-ID CWE-532
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
Openshift assisted-installer
Universal components / Libraries / Programming Languages & Components

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Inclusion of Sensitive Information in Log Files

EUVDB-ID: #VU68864

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-3684

CWE-ID: CWE-532 - Information Exposure Through Log Files

Exploit availability: No

Description

The vulnerability allows a local user to gain access to sensitive information.

The vulnerability exists due to during generation of the Discovery ISO, image pull secrets were leaked as plaintext in the installation logs. A local user can exploit this by re-using the image pull secret to pull container images from the registry as the associated user.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Openshift assisted-installer: 1.0.9 - 1.0.24.3


CPE2.3 External links

http://bugzilla.redhat.com/show_bug.cgi?id=1985962

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###