Multiple vulnerabilities in Pillow



Published: 2022-11-22
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2022-24303
CVE-2022-22817
CWE-ID CWE-20
CWE-749
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Pillow
Universal components / Libraries / Libraries used by multiple products

Vendor Alex Clark and Contributors

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Input validation error

EUVDB-ID: #VU69497

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-24303

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to delete arbitrary files on the system.

The vulnerability exists due to input validation error when processing spaces in path to the temporary directory on Linux or macOS. A remote attacker can pass a specially crafted file to the application and delete arbitrary files on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Pillow: 1.0 - 9.0.0


CPE2.3 External links

http://pillow.readthedocs.io/en/stable/releasenotes/9.0.1.html#security

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Exposed dangerous method or function

EUVDB-ID: #VU60003

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-22817

CWE-ID: CWE-749 - Exposed Dangerous Method or Function

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected system.

The vulnerability exists due to usage of PIL.ImageMath.eval() function on arbitrary expressions. A remote attacker can pass specially crafted file to the library and execute arbitrary code on the system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Pillow: 1.0 - 9.0.0


CPE2.3 External links

http://pillow.readthedocs.io/en/stable/releasenotes/9.0.1.html#security

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###