Multiple vulnerabilities in Foxit PDF Editor for Mac



Published: 2022-11-23
Risk Low
Patch available YES
Number of vulnerabilities 4
CVE-ID N/A
CWE-ID CWE-476
CWE-125
CWE-399
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Foxit PDF Editor for Mac (formerly PhantomPDF)
Client/Desktop applications / Office applications

Vendor Foxit Software Inc.

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) NULL pointer dereference

EUVDB-ID: #VU69524

Risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error when processing JavaScript in PDF files. A remote attacker can trick the victim to open a specially crafted PDF file and crash the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Editor for Mac (formerly PhantomPDF): 11.0.0.0510 - 11.1.3.0920


CPE2.3 External links

http://www.foxitsoftware.com/support/security-bulletins.html?Security+update+available+in+Foxit+PDF+Editor+for+Mac+11.1.4+2022-11-23+00%3A00%3A00

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Out-of-bounds read

EUVDB-ID: #VU69526

Risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-125 - Out-of-bounds read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a boundary condition when processing U3D files. A remote attacker can create a specially crafted U3D file, trick the victim into opening it, trigger out-of-bounds read error and read contents of memory on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Editor for Mac (formerly PhantomPDF): 11.0.0.0510 - 11.1.3.0920


CPE2.3 External links

http://www.foxitsoftware.com/support/security-bulletins.html?Security+update+available+in+Foxit+PDF+Editor+for+Mac+11.1.4+2022-11-23+00%3A00%3A00

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) NULL pointer dereference

EUVDB-ID: #VU69527

Risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error when processing JavaScript in PDF files with the colSpan attribute is set beyond the maximum length allowed. A remote attacker can trick the victim to open a specially crafted PDF file and crash the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Editor for Mac (formerly PhantomPDF): 11.0.0.0510 - 11.1.3.0920


CPE2.3 External links

http://www.foxitsoftware.com/support/security-bulletins.html?Security+update+available+in+Foxit+PDF+Editor+for+Mac+11.1.4+2022-11-23+00%3A00%3A00

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) Resource management error

EUVDB-ID: #VU69528

Risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper management of internal resources within the application when handling PDF or XFA files. A remote attacker can trick the victim to open a specially crafted file and crash the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Editor for Mac (formerly PhantomPDF): 11.0.0.0510 - 11.1.3.0920


CPE2.3 External links

http://www.foxitsoftware.com/support/security-bulletins.html?Security+update+available+in+Foxit+PDF+Editor+for+Mac+11.1.4+2022-11-23+00%3A00%3A00

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###