Arbitrary file upload in PostmagThemes Demo plugin for WordPress



Published: 2022-11-29
Risk High
Patch available NO
Number of vulnerabilities 1
CVE-ID CVE-2022-1540
CWE-ID CWE-434
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
PostmagThemes Demo Import
Web applications / Modules and components for CMS

Vendor postmagthemes

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Arbitrary file upload

EUVDB-ID: #VU69661

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-1540

CWE-ID: CWE-434 - Unrestricted Upload of File with Dangerous Type

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to insufficient validation of file during file upload. A remote attacker can upload a malicious file and execute it on the server.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

PostmagThemes Demo Import: 1.0.1 - 1.0.7


CPE2.3 External links

http://patchstack.com/database/vulnerability/postmagthemes-demo-import/wordpress-postmagthemes-demo-plugin-1-0-7-auth-arbitrary-file-upload-vulnerability

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###