Remote code execution in FreeBSD ping(8)



Published: 2022-11-30
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-23093
CWE-ID CWE-121
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
FreeBSD
Operating systems & Components / Operating system

Vendor FreeBSD Foundation

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Stack-based buffer overflow

EUVDB-ID: #VU69732

Risk: High

CVSSv3.1:

CVE-ID: CVE-2022-23093

CWE-ID: CWE-121 - Stack-based buffer overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error within the pr_pack() function in ping(8) when processing IP option headers following the IP header in either the response or the quoted packet. A remote attacker can send a specially crafted ICMP response to the affected system, trigger a stack-based buffer overflow and potentially execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system but requires the victim to ping a malicious host.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

FreeBSD: 12.0 - 13.1


CPE2.3 External links

http://www.freebsd.org/security/advisories/FreeBSD-SA-22:15.ping.asc

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###