Multiple vulnerabilities in Jenkins Orka by MacStadium plugin



Published: 2023-01-25
Risk Medium
Patch available YES
Number of vulnerabilities 3
CVE-ID CVE-2023-24431
CVE-2023-24432
CVE-2023-24433
CWE-ID CWE-264
CWE-352
CWE-284
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Orka by MacStadium
Web applications / Modules and components for CMS

Vendor Jenkins

Security Bulletin

This security bulletin contains information about 3 vulnerabilities.

1) Permissions, Privileges, and Access Controls

EUVDB-ID: #VU71521

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-24431

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to the affected plugin does not perform permission checks in several HTTP endpoints. A remote user can gain unauthorized access to sensitive information on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Orka by MacStadium: 1.0 - 1.31


CPE2.3 External links

http://jenkins.io/security/advisory/2023-01-24/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Cross-site request forgery

EUVDB-ID: #VU71522

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2023-24432

CWE-ID: CWE-352 - Cross-Site Request Forgery (CSRF)

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform cross-site request forgery attacks.

The vulnerability exists due to insufficient validation of the HTTP request origin. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Orka by MacStadium: 1.0 - 1.31


CPE2.3 External links

http://jenkins.io/security/advisory/2023-01-24/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Improper access control

EUVDB-ID: #VU71523

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2023-24433

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.

The vulnerability exists due to improper access restrictions in several HTTP endpoints. A remote user can connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Orka by MacStadium: 1.0 - 1.31


CPE2.3 External links

http://jenkins.io/security/advisory/2023-01-24/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###