OS Command Injection in IBM CICS TX Standard



Published: 2023-09-27
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2022-33955
CWE-ID CWE-78
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
IBM CICS TX Standard
Universal components / Libraries / Software for developers

Vendor IBM Corporation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) OS Command Injection

EUVDB-ID: #VU81239

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-33955

CWE-ID: CWE-78 - Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Exploit availability: No

Description

The vulnerability allows an attacker with physical access to execute arbitrary shell commands on the target system.

The vulnerability exists due to improper input validation. An unauthenticated attacker with physical access can pass specially crafted data to the application and execute arbitrary OS commands on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

IBM CICS TX Standard: before 11.1 127636

CPE2.3 External links

http://www.ibm.com/support/pages/node/6608190


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###