Incorrect Implementation of Authentication Algorithm in D-LINK DIR-X4860



Published: 2024-05-15
Risk High
Patch available NO
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-303
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
DIR-X4860
Hardware solutions / Routers for home users

Vendor D-Link

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Incorrect Implementation of Authentication Algorithm

EUVDB-ID: #VU89535

Risk: High

CVSSv3.1: 9.3 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:U/RC:C]

CVE-ID: N/A

CWE-ID: CWE-303 - Incorrect Implementation of Authentication Algorithm

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to incorrect implementation of authentication algorithm within prog.cgi, which handles HNAP login requests. A remote attacker can escalate privileges and execute arbitrary code on the target device.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

DIR-X4860: 1.04B03

External links

http://ssd-disclosure.com/ssd-advisory-d-link-dir-x4860-security-vulnerabilities/


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected device in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



###SIDEBAR###