Vulnerabilities in Agora SDK 3.1