Vulnerabilities in The Official Facebook Chat Plugin 1.6