Vulnerabilities in smarty.php.net software