Code Injection in needrestart - CVE-2024-48990
Published: November 27, 2024 / Updated: January 4, 2026
Vulnerability details
The vulnerability allows a local user to escalate privileges on the system.
The vulnerability exists due to insecure handling of environment variables. A local user can trick the application into running the Python interpreter with an attacker-controlled PYTHONPATH environment variable and execute arbitrary code on the system as root.
Affected software
Debian Linux
Gentoo Linux
Fedora
Ubuntu
libmodule-scandeps-perl (Ubuntu package)
needrestart (Ubuntu package)
needrestart
app-admin/needrestart
needrestart (Debian package)
OpenManage Network Integration (OMNI)
How to mitigate CVE-2024-48990
libmodule-scandeps-perl (Ubuntu package) - addressed in versions 1.20-1ubuntu0.1~esm1, 1.24-1ubuntu0.1~esm1, 1.27-1ubuntu0.1~esm1, 1.31-1ubuntu0.1, 1.35-1ubuntu0.24.04.1, 1.35-1ubuntu0.24.10.1
needrestart (Ubuntu package) - addressed in versions Ubuntu Pro, 2.6-1ubuntu0.1~esm1, 3.1-1ubuntu0.1+esm1, 3.4-6ubuntu0.1+esm1, 3.5-5ubuntu2.2, 3.5-5ubuntu2.3, 3.5-5ubuntu2.4, 3.6-7ubuntu4.3, 3.6-7ubuntu4.4, 3.6-7ubuntu4.5, 3.6-8ubuntu4.2, 3.6-8ubuntu4.3, 3.6-8ubuntu4.4
needrestart - addressed in versions 3.8-1.el8, 3.8-1.el9, 3.8-1.fc39, 3.8-1.fc40, 3.8-1.fc41
OpenManage Network Integration (OMNI) - update to 3.7
app-admin/needrestart - update to 3.8
needrestart (Debian package) - update to 3.6-4+deb12u2
Links to Public Exploits and PoC-codes
- Exploit #12247 - needrestart-privesc-cve-2024-48990 (Local privilege escalation exploit for needrestart (CVE-2024-48990)) (January 4, 2026)
- Exploit #12057 - CVE-2024-48990-Automatic-Exploit (October 31, 2025)
- Exploit #11048 - Ubuntu needrestart Privilege Escalation (January 10, 2025)
- Exploit #10929 - exploits-poc (This repository contains PoC exploits we developed for internal research or red team exercises.) (November 29, 2024)
- Exploit #10922 - CVE-2024-48990-exploit (Needrestart, prior to version 3.8, contains a vulnerability that allows local attackers to execute arbitrary code with root privileges. This is achieved by manipulating the PYTHONPATH environment variable to trick needrestart into (November 29, 2024)
- Exploit #10914 - CVE-2024-48990 (November 29, 2024)
External References
Related Security Bulletins
- Multiple privilege escalation vulnerabilities in needrestart
- Debian update for needrestart
- Ubuntu update for needrestart
- Fedora EPEL 9 update for needrestart
- Fedora EPEL 8 update for needrestart
- Fedora 40 update for needrestart
- Fedora 41 update for needrestart
- Fedora 39 update for needrestart
- Ubuntu update for needrestart
- Multiple vulnerabilities in Dell OpenManage Network Integration (OMNI)
- Gentoo update for needrestart
- Ubuntu update for libmodule-scandeps-perl, needrestart