Buffer over-read in GraphicsMagick - CVE-2017-17913
Published: December 27, 2017 / Updated: January 29, 2018
Vulnerability details
The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.
The vulnerability exists due to stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type. A remote attacker can perform a denial of service attack.
Affected software
Amazon Linux AMI
Fedora
Ubuntu
graphicsmagick (Ubuntu package)
libgraphicsmagick-q16-3 (Ubuntu package)
libgraphicsmagick++-q16-12 (Ubuntu package)
GraphicsMagick
How to mitigate CVE-2017-17913
libgraphicsmagick-q16-3 (Ubuntu package) - update to 1.3.23-1ubuntu0.6
libgraphicsmagick++-q16-12 (Ubuntu package) - update to 1.3.23-1ubuntu0.6
GraphicsMagick - addressed in versions 1.3.28-1.el6, 1.3.28-1.el7, 1.3.28-1.fc26, 1.3.28-1.fc27