Information disclosure in PHP - CVE-2010-2484

 

Information disclosure in PHP - CVE-2010-2484

Published: August 23, 2016 / Updated: June 8, 2025


Vulnerability identifier: #VU110287
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2010-2484
CWE-ID: CWE-200
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The strrchr function in PHP 5.2 before 5.2.14 allows context-dependent attackers to obtain sensitive information (memory contents) or trigger memory corruption by causing a userspace interruption of an internal function or handler.


Affected software

PHP
Gentoo Linux
Ubuntu
libapache2-mod-php5 (Ubuntu package)
php5-common (Ubuntu package)
php5-cli (Ubuntu package)
php5-cgi (Ubuntu package)
dev-lang/php

How to mitigate CVE-2010-2484

Install update from vendor's website.

PHP - update to 5.2.14
libapache2-mod-php5 (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.18, 5.3.2-1ubuntu4.10, 5.3.3-1ubuntu9.6, 5.3.5-1ubuntu7.3, 5.3.6-13ubuntu3.2
php5-common (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.18, 5.3.2-1ubuntu4.10, 5.3.3-1ubuntu9.6, 5.3.5-1ubuntu7.3, 5.3.6-13ubuntu3.2
php5-cli (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.18, 5.3.2-1ubuntu4.10, 5.3.3-1ubuntu9.6, 5.3.5-1ubuntu7.3, 5.3.6-13ubuntu3.2
php5-cgi (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.18, 5.3.2-1ubuntu4.10, 5.3.3-1ubuntu9.6, 5.3.5-1ubuntu7.3, 5.3.6-13ubuntu3.2
dev-lang/php - update to 5.3.8

External References

Related Security Bulletins