Input validation error in PHP - CVE-2007-0907

 

Input validation error in PHP - CVE-2007-0907

Published: October 30, 2018 / Updated: June 8, 2025


Vulnerability identifier: #VU110460
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2007-0907
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

Buffer underflow in PHP before 5.2.1 allows attackers to cause a denial of service via unspecified vectors involving the sapi_header_op function.


Affected software

PHP
Gentoo Linux
Ubuntu
php5-cli (Ubuntu package)
php5-cgi (Ubuntu package)
php5-odbc (Ubuntu package)
php5-common (Ubuntu package)
libapache2-mod-php5 (Ubuntu package)
dev-lang/php

How to mitigate CVE-2007-0907

Install update from vendor's website.

PHP - addressed in versions 4.4.5, 4.10, 5.2.0
php5-cli (Ubuntu package) - addressed in versions 5.0.5-2ubuntu1.7, 5.1.2-1ubuntu3.5, 5.1.6-1ubuntu2.2
php5-cgi (Ubuntu package) - addressed in versions 5.0.5-2ubuntu1.7, 5.1.2-1ubuntu3.5, 5.1.6-1ubuntu2.2
php5-odbc (Ubuntu package) - addressed in versions 5.0.5-2ubuntu1.7, 5.1.2-1ubuntu3.5, 5.1.6-1ubuntu2.2
php5-common (Ubuntu package) - addressed in versions 5.0.5-2ubuntu1.7, 5.1.2-1ubuntu3.5, 5.1.6-1ubuntu2.2
libapache2-mod-php5 (Ubuntu package) - addressed in versions 5.0.5-2ubuntu1.7, 5.1.2-1ubuntu3.5, 5.1.6-1ubuntu2.2
dev-lang/php - update to 5.2.1-r3

External References

Related Security Bulletins