Input validation error in FFmpeg - CVE-2014-9604
Published: December 3, 2016 / Updated: June 8, 2025
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
libavcodec/utvideodec.c in FFmpeg before 2.5.2 does not check for a zero value of a slice height, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted Ut Video data, related to the (1) restore_median and (2) restore_median_il functions.
Affected software
Gentoo Linux
Ubuntu
libavcodec53 (Ubuntu package)
libavformat53 (Ubuntu package)
media-video/ffmpeg
How to mitigate CVE-2014-9604
libavcodec53 (Ubuntu package) - update to 4:0.8.17-0ubuntu0.12.04.1
libavformat53 (Ubuntu package) - update to 4:0.8.17-0ubuntu0.12.04.1
media-video/ffmpeg - update to 2.6.3