Buffer overflow in FFmpeg - CVE-2014-8547
Published: December 3, 2016 / Updated: June 8, 2025
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
libavcodec/gifdec.c in FFmpeg before 2.4.2 does not properly compute image heights, which allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted GIF data.
Affected software
Gentoo Linux
Ubuntu
libavcodec53 (Ubuntu package)
libavformat53 (Ubuntu package)
media-video/ffmpeg
How to mitigate CVE-2014-8547
libavcodec53 (Ubuntu package) - update to 4:0.8.17-0ubuntu0.12.04.1
libavformat53 (Ubuntu package) - update to 4:0.8.17-0ubuntu0.12.04.1
media-video/ffmpeg - update to 2.6.3