Memory leak in Linux kernel - CVE-2019-19079
Published: January 17, 2020
Vulnerability identifier: #VU24383
CSH Severity: Low
CVSS v4: 6.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2019-19079
CWE-ID: CWE-401
Exploitation vector: Local access
Exploit availability:
No public exploit available
Vulnerability details
The vulnerability allows a local user to perform a denial of service (DoS) attack.
The vulnerability exists due to memory leak within the qrtr_tun_write_iter() function in net/qrtr/tun.c in the Linux kernel before 5.3 allows a local user to cause a denial of service (memory consumption).
Affected software
Linux kernel
Ubuntu
linux-gcp (Ubuntu package)
linux-oracle-5.0 (Ubuntu package)
linux-gke-5.0 (Ubuntu package)
linux-aws-5.0 (Ubuntu package)
Ubuntu
linux-gcp (Ubuntu package)
linux-oracle-5.0 (Ubuntu package)
linux-gke-5.0 (Ubuntu package)
linux-aws-5.0 (Ubuntu package)
How to mitigate CVE-2019-19079
Install update from vendor's website.
Linux kernel - update to 5.3
linux-gcp (Ubuntu package) - update to 5.0.0-1029.30~18.04.1
linux-oracle-5.0 (Ubuntu package) - update to 5.0.0-1010.15~18.04.1
linux-gke-5.0 (Ubuntu package) - update to 5.0.0-1029.30~18.04.1
linux-aws-5.0 (Ubuntu package) - update to 5.0.0-1024.27~18.04.1
linux-gcp (Ubuntu package) - update to 5.0.0-1029.30~18.04.1
linux-oracle-5.0 (Ubuntu package) - update to 5.0.0-1010.15~18.04.1
linux-gke-5.0 (Ubuntu package) - update to 5.0.0-1029.30~18.04.1
linux-aws-5.0 (Ubuntu package) - update to 5.0.0-1024.27~18.04.1