Input validation error in Linux kernel - CVE-2010-2963
Published: November 26, 2010 / Updated: July 20, 2020
Vulnerability details
The vulnerability allows a local user to escalate privileges on the system.
drivers/media/video/v4l2-compat-ioctl32.c in the Video4Linux (V4L) implementation in the Linux kernel before 2.6.36 on 64-bit platforms does not validate the destination of a memory copy operation, which allows local users to write to arbitrary kernel memory locations, and consequently gain privileges, via a VIDIOCSTUNER ioctl call on a /dev/video device, followed by a VIDIOCSMICROCODE ioctl call on this device.
Affected software
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux (Ubuntu package)
How to mitigate CVE-2010-2963
linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-55.89
linux (Ubuntu package) - addressed in versions 2.6.24-28.80, 2.6.28-19.66, 2.6.31-22.67, 2.6.32-25.45, 2.6.35-22.35