Memory leak in Linux kernel - CVE-2019-19076

 

Memory leak in Linux kernel - CVE-2019-19076

Published: November 18, 2019 / Updated: June 1, 2020


Vulnerability identifier: #VU28413
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2019-19076
CWE-ID: CWE-401
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to memory leak within the nfp_abm_u32_knode_replace() function in drivers/net/ethernet/netronome/nfp/abm/cls.c in the Linux kernel before 5.3.6 allows attackers to cause a denial of service (memory consumption), aka CID-78beef629fd9. NOTE: This has been argued as not a valid vulnerability. The upstream commit 78beef629fd9 was reverted. A remote attacker can perform a denial of service attack.


Affected software

Linux kernel
Ubuntu
linux-gcp (Ubuntu package)
linux-oracle (Ubuntu package)
linux-hwe (Ubuntu package)
linux (Ubuntu package)
linux-aws (Ubuntu package)
linux-kvm (Ubuntu package)
linux-raspi2 (Ubuntu package)
linux-oracle-5.0 (Ubuntu package)
linux-oem-osp1 (Ubuntu package)
linux-gke-5.0 (Ubuntu package)
linux-aws-5.0 (Ubuntu package)

How to mitigate CVE-2019-19076

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Linux kernel - update to 5.6
linux-gcp (Ubuntu package) - addressed in versions 5.0.0-1026.27~18.04.1, 5.0.0-1026.27
linux-oracle (Ubuntu package) - update to 5.0.0-1008.13
linux-hwe (Ubuntu package) - update to 5.0.0-37.40~18.04.1
linux (Ubuntu package) - update to 5.0.0-37.40
linux-aws (Ubuntu package) - update to 5.0.0-1022.25
linux-kvm (Ubuntu package) - update to 5.0.0-1023.25
linux-raspi2 (Ubuntu package) - update to 5.0.0-1023.24
linux-oracle-5.0 (Ubuntu package) - update to 5.0.0-1008.13~18.04.1
linux-oem-osp1 (Ubuntu package) - update to 5.0.0-1030.34
linux-gke-5.0 (Ubuntu package) - update to 5.0.0-1026.27~18.04.2
linux-aws-5.0 (Ubuntu package) - update to 5.0.0-1022.25~18.04.1

External References

Related Security Bulletins