Information disclosure in mod_wsgi - CVE-2014-0242
Published: December 9, 2019 / Updated: July 20, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.
mod_wsgi module before 3.4 for Apache, when used in embedded mode, might allow remote attackers to obtain sensitive information via the Content-Type header which is generated from memory that may have been freed and then overwritten by a separate thread.
Affected software
libapache2-mod-wsgi (Ubuntu package)
libapache2-mod-wsgi-py3 (Ubuntu package)
python26-mod_wsgi
Amazon Linux AMI
Gentoo Linux
Fedora
Ubuntu
How to mitigate CVE-2014-0242
libapache2-mod-wsgi (Ubuntu package) - addressed in versions 3.3-4ubuntu0.1, 3.4-4ubuntu2.1.13.10.1, 3.4-4ubuntu2.1.14.04.1
libapache2-mod-wsgi-py3 (Ubuntu package) - addressed in versions 3.3-4ubuntu0.1, 3.4-4ubuntu2.1.13.10.1, 3.4-4ubuntu2.1.14.04.1
mod_wsgi - update to 3.5-1.el5
python26-mod_wsgi - update to 3.5-1.el5