Operation on a Resource after Expiration or Release in Linux kernel - CVE-2019-19602

 

Operation on a Resource after Expiration or Release in Linux kernel - CVE-2019-19602

Published: December 5, 2019 / Updated: July 17, 2020


Vulnerability identifier: #VU30560
CSH Severity: Low
CVSS v4: 6.9 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2019-19602
CWE-ID: CWE-672
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local authenticated user to #BASIC_IMPACT#.

fpregs_state_valid in arch/x86/include/asm/fpu/internal.h in the Linux kernel before 5.4.2, when GCC 9 is used, allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact because of incorrect fpu_fpregs_owner_ctx caching, as demonstrated by mishandling of signal-based non-cooperative preemption in Go 1.14 prereleases on amd64, aka CID-59c4bd853abc.


Affected software

Linux kernel
Ubuntu
linux-oracle (Ubuntu package)
linux-hwe (Ubuntu package)
linux (Ubuntu package)
linux-aws (Ubuntu package)
linux-gcp (Ubuntu package)
linux-kvm (Ubuntu package)
linux-azure (Ubuntu package)
linux-raspi2 (Ubuntu package)
linux-gcp-5.3 (Ubuntu package)
linux-azure-5.3 (Ubuntu package)
linux-raspi2-5.3 (Ubuntu package)

How to mitigate CVE-2019-19602

Install update from vendor's website.

Linux kernel - update to 5.4.2
linux-oracle (Ubuntu package) - update to 5.3.0-1009.10
linux-hwe (Ubuntu package) - update to 5.3.0-40.32~18.04.1
linux (Ubuntu package) - update to 5.3.0-40.32
linux-aws (Ubuntu package) - update to 5.3.0-1011.12
linux-gcp (Ubuntu package) - update to 5.3.0-1012.13
linux-kvm (Ubuntu package) - update to 5.3.0-1010.11
linux-azure (Ubuntu package) - update to 5.3.0-1013.14
linux-raspi2 (Ubuntu package) - update to 5.3.0-1018.20
linux-gcp-5.3 (Ubuntu package) - update to 5.3.0-1012.13~18.04.1
linux-azure-5.3 (Ubuntu package) - update to 5.3.0-1013.14~18.04.1
linux-raspi2-5.3 (Ubuntu package) - update to 5.3.0-1018.20~18.04.1

External References

Related Security Bulletins