Information disclosure in PostgreSQL - CVE-2015-3167
Published: November 20, 2019 / Updated: July 17, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.
contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which makes it easier for attackers to obtain the key via a brute force attack.
Affected software
Amazon Linux AMI
Gentoo Linux
Ubuntu
postgresql (Alpine package)
postgresql-9.1 (Ubuntu package)
postgresql-9.3 (Ubuntu package)
postgresql-9.4 (Ubuntu package)
How to mitigate CVE-2015-3167
postgresql (Alpine package) - update to 9.3.7-r0
postgresql-9.1 (Ubuntu package) - update to 9.1.16-0ubuntu0.12.04
postgresql-9.3 (Ubuntu package) - update to 9.3.7-0ubuntu0.14.04
postgresql-9.4 (Ubuntu package) - addressed in versions 9.4.2-0ubuntu0.14.10, 9.4.2-0ubuntu0.15.04
External References
- http://ubuntu.com/usn/usn-2621-1
- http://www.debian.org/security/2015/dsa-3269
- http://www.debian.org/security/2015/dsa-3270
- http://www.postgresql.org/about/news/1587/
- http://www.postgresql.org/docs/9.0/static/release-9-0-20.html
- http://www.postgresql.org/docs/9.1/static/release-9-1-16.html
- http://www.postgresql.org/docs/9.2/static/release-9-2-11.html
- http://www.postgresql.org/docs/9.3/static/release-9-3-7.html
- http://www.postgresql.org/docs/9.4/static/release-9-4-2.html