Link following in Puppet Agent - CVE-2013-4969
Published: January 7, 2014 / Updated: July 26, 2020
Vulnerability identifier: #VU31880
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-4969
CWE-ID: CWE-59
Exploitation vector: Local access
Exploit availability:
No public exploit available
Vulnerability details
The vulnerability allows a local non-authenticated attacker to manipulate data.
Puppet before 3.3.3 and 3.4 before 3.4.1 and Puppet Enterprise (PE) before 2.8.4 and 3.1 before 3.1.1 allows local users to overwrite arbitrary files via a symlink attack on unspecified files.
Affected software
Puppet Agent
Amazon Linux AMI
Fedora
Ubuntu
puppet-common (Ubuntu package)
puppet
Amazon Linux AMI
Fedora
Ubuntu
puppet-common (Ubuntu package)
puppet
How to mitigate CVE-2013-4969
Install update from vendor's website.
Puppet Agent - update to 3.4.1
puppet-common (Ubuntu package) - addressed in versions 2.7.11-1ubuntu2.6, 2.7.18-1ubuntu1.4, 2.7.18-4ubuntu1.3, 3.2.4-2ubuntu2.2
puppet - update to 2.7.24-1.el6
puppet-common (Ubuntu package) - addressed in versions 2.7.11-1ubuntu2.6, 2.7.18-1ubuntu1.4, 2.7.18-4ubuntu1.3, 3.2.4-2ubuntu2.2
puppet - update to 2.7.24-1.el6