Link following in CUPS - CVE-2013-6891
Published: January 26, 2014 / Updated: July 28, 2020
Vulnerability details
The vulnerability allows a local non-authenticated attacker to gain access to sensitive information.
lppasswd in CUPS before 1.7.1, when running with setuid privileges, allows local users to read portions of arbitrary files via a modified HOME environment variable and a symlink attack involving .cups/client.conf.
Affected software
Ubuntu
cups (Alpine package)
cups-client (Ubuntu package)
How to mitigate CVE-2013-6891
cups (Alpine package) - update to 1.7.1-r0
cups-client (Ubuntu package) - addressed in versions 1.6.1-0ubuntu11.5, 1.6.2-1ubuntu8, 1.7.0~rc1-0ubuntu5.2