Permissions, Privileges, and Access Controls in libvirt - CVE-2013-4311

 

Permissions, Privileges, and Access Controls in libvirt - CVE-2013-4311

Published: October 4, 2013 / Updated: July 28, 2020


Vulnerability identifier: #VU32594
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-4311
CWE-ID: CWE-264
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local non-authenticated attacker to read and manipulate data.

libvirt 1.0.5.x before 1.0.5.6, 0.10.2.x before 0.10.2.8, and 0.9.12.x before 0.9.12.2 allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition in pkcheck via a (1) setuid process or (2) pkexec process, a related issue to CVE-2013-4288.


Affected software

libvirt
Ubuntu
libvirt (Alpine package)
libvirt0 (Ubuntu package)
libvirt-bin (Ubuntu package)

How to mitigate CVE-2013-4311

Install update from vendor's website.

libvirt (Alpine package) - update to 1.0.5.8-r0
libvirt0 (Ubuntu package) - addressed in versions 0.7.5-5ubuntu27.24, 0.9.8-2ubuntu17.13, 0.9.13-0ubuntu12.5, 1.0.2-0ubuntu11.13.04.4
libvirt-bin (Ubuntu package) - addressed in versions 0.7.5-5ubuntu27.24, 0.9.8-2ubuntu17.13, 0.9.13-0ubuntu12.5, 1.0.2-0ubuntu11.13.04.4

External References

Related Security Bulletins