Heap-based buffer overflow in Samba - CVE-2013-4408

 

Heap-based buffer overflow in Samba - CVE-2013-4408

Published: December 10, 2013 / Updated: July 28, 2020


Vulnerability identifier: #VU32598
CSH Severity: High
CVSS v4: 8.7 [CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-4408
CWE-ID: CWE-122
Exploitation vector: Adjecent network
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in Heap-based buffer overflow in the dcerpc_read_ncacn_packet_done function in librpc/rpc/dcerpc_util.c in winbindd in Samba 3.x before 3.6.22, 4.0.x before 4.0.13, and 4.1.x before 4.1.3. A remote attacker can use an invalid fragment length in a DCE-RPC packet. to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.


Affected software

Samba
Ubuntu
SUSE Linux
Slackware Linux
samba (Alpine package)
winbind (Ubuntu package)
samba (Ubuntu package)
libpam-winbind (Ubuntu package)

How to mitigate CVE-2013-4408

Update to version 3.6.22.

Samba - update to 3.6.22
samba (Alpine package) - update to 3.6.22-r0
winbind (Ubuntu package) - update to 2:3.4.7~dfsg-1ubuntu3.13
samba (Ubuntu package) - addressed in versions 2:3.4.7~dfsg-1ubuntu3.13, 2:3.6.3-2ubuntu2.9, 2:3.6.6-3ubuntu5.3, 2:3.6.9-1ubuntu1.2, 2:3.6.18-1ubuntu3.1
libpam-winbind (Ubuntu package) - addressed in versions 2:3.6.3-2ubuntu2.9, 2:3.6.6-3ubuntu5.3, 2:3.6.9-1ubuntu1.2, 2:3.6.18-1ubuntu3.1

External References

Related Security Bulletins