Buffer overflow in xcmsdb - CVE-2013-2001
Published: June 15, 2013 / Updated: July 28, 2020
Vulnerability identifier: #VU32669
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2001
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability:
No public exploit available
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Buffer overflow in X.org libXxf86vm 1.1.2 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XF86VidModeGetGammaRamp function.
Affected software
xcmsdb
Amazon Linux AMI
Ubuntu
libxxf86vm (Alpine package)
libxxf86vm1 (Ubuntu package)
Amazon Linux AMI
Ubuntu
libxxf86vm (Alpine package)
libxxf86vm1 (Ubuntu package)
How to mitigate CVE-2013-2001
Install update from vendor's website.
xcmsdb - update to 1.1.3
libxxf86vm (Alpine package) - update to 1.1.2-r1
libxxf86vm1 (Ubuntu package) - addressed in versions 1:1.1.0-2ubuntu0.1, 1:1.1.1-2ubuntu0.1, 1:1.1.2-1ubuntu0.12.10.1, 1:1.1.2-1ubuntu0.13.04.1
libxxf86vm (Alpine package) - update to 1.1.2-r1
libxxf86vm1 (Ubuntu package) - addressed in versions 1:1.1.0-2ubuntu0.1, 1:1.1.1-2ubuntu0.1, 1:1.1.2-1ubuntu0.12.10.1, 1:1.1.2-1ubuntu0.13.04.1
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106872.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00165.html
- http://www.debian.org/security/2013/dsa-2692
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1870-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23