Buffer overflow in file - CVE-2012-1571
Published: July 18, 2012 / Updated: July 28, 2020
Vulnerability identifier: #VU32802
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2012-1571
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability:
No public exploit available
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to perform service disruption.
file before 5.11 and libmagic allow remote attackers to cause a denial of service (crash) via a crafted Composite Document File (CDF) file that triggers (1) an out-of-bounds read or (2) an invalid pointer dereference.
Affected software
file
Gentoo Linux
Amazon Linux AMI
Ubuntu
file (Alpine package)
libmagic1 (Ubuntu package)
file (Ubuntu package)
Gentoo Linux
Amazon Linux AMI
Ubuntu
file (Alpine package)
libmagic1 (Ubuntu package)
file (Ubuntu package)
How to mitigate CVE-2012-1571
Install update from vendor's website.
file - update to 5.11
file (Alpine package) - update to 5.11-r0
libmagic1 (Ubuntu package) - addressed in versions 5.03-5ubuntu1.1, 5.09-2ubuntu0.2, 5.11-2ubuntu0.1, 5.11-2ubuntu4.1
file (Ubuntu package) - addressed in versions 5.03-5ubuntu1.1, 5.09-2ubuntu0.2, 5.11-2ubuntu0.1, 5.11-2ubuntu4.1
file (Alpine package) - update to 5.11-r0
libmagic1 (Ubuntu package) - addressed in versions 5.03-5ubuntu1.1, 5.09-2ubuntu0.2, 5.11-2ubuntu0.1, 5.11-2ubuntu4.1
file (Ubuntu package) - addressed in versions 5.03-5ubuntu1.1, 5.09-2ubuntu0.2, 5.11-2ubuntu0.1, 5.11-2ubuntu4.1
External References
- http://mx.gw.com/pipermail/file/2012/000914.html
- http://www.debian.org/security/2012/dsa-2422
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:035
- http://www.ubuntu.com/usn/USN-2123-1
- https://github.com/glensc/file/commit/1859fdb4e67c49c463c4e0078054335cd46ba295
- https://github.com/glensc/file/commit/1aec04dbf8a24b8a6ba64c4f74efa0628e36db0b