Input validation error in PHP - CVE-2011-4885

 

Input validation error in PHP - CVE-2011-4885

Published: December 30, 2011 / Updated: July 29, 2020


Vulnerability identifier: #VU32831
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-4885
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: Public exploit is available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

PHP before 5.3.9 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.


Affected software

PHP
Amazon Linux AMI
Gentoo Linux
Ubuntu
php (Alpine package)
libapache2-mod-php5 (Ubuntu package)
php5 (Ubuntu package)
php5-cgi (Ubuntu package)
php5-cli (Ubuntu package)
php5-xsl (Ubuntu package)
php5-common (Ubuntu package)

How to mitigate CVE-2011-4885

Install update from vendor's website.

PHP - update to 5.3.9
php (Alpine package) - addressed in versions 5.3.8-r1, 5.3.8-r2
libapache2-mod-php5 (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5
php5 (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5
php5-cgi (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5
php5-cli (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5
php5-xsl (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5
php5-common (Ubuntu package) - addressed in versions 5.2.4-2ubuntu5.22, 5.3.2-1ubuntu4.13, 5.3.3-1ubuntu9.9, 5.3.5-1ubuntu7.6, 5.3.6-13ubuntu3.5

Links to Public Exploits and PoC-codes

External References

Related Security Bulletins