Code Injection in FFmpeg - cve-2011-3504

 

Code Injection in FFmpeg - cve-2011-3504

Published: September 29, 2011 / Updated: July 28, 2020


Vulnerability identifier: #VU32843
CSH Severity: High
CVSS v4: 9.3 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: cve-2011-3504
CWE-ID: CWE-94
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.


Affected software

FFmpeg
Ubuntu
ffmpeg (Alpine package)
libavformat52 (Ubuntu package)
libavcodec52 (Ubuntu package)
libavcodec53 (Ubuntu package)
libavformat53 (Ubuntu package)

How to mitigate cve-2011-3504

Install update from vendor's website.

FFmpeg - update to 0.8.3
ffmpeg (Alpine package) - update to 0.6.1-r2
libavformat52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1
libavformat53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1

External References

Related Security Bulletins