Heap-based buffer overflow - CVE-2011-2911

 

Heap-based buffer overflow - CVE-2011-2911

Published: June 7, 2012 / Updated: August 3, 2020


Vulnerability identifier: #VU33120
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-2911
CWE-ID: CWE-122
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in Integer overflow in the CSoundFile::ReadWav function in src/load_wav.cpp in libmodplug before 0.8.8.4. A remote attacker can use a crafted WAV file to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.


Affected software

Gentoo Linux
Ubuntu
libmodplug (Alpine package)
libvpx (Alpine package)
libmodplug0c2 (Ubuntu package)
libmodplug1 (Ubuntu package)

How to mitigate CVE-2011-2911

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

libmodplug (Alpine package) - update to 0.8.8.4-r0
libvpx (Alpine package) - update to 1.0.0-r0
libmodplug0c2 (Ubuntu package) - update to 1:0.8.7-1ubuntu0.3
libmodplug1 (Ubuntu package) - addressed in versions 1:0.8.8.1-1ubuntu1.3, 1:0.8.8.1-2ubuntu0.3, 1:0.8.8.2-3ubuntu1.1

External References

Related Security Bulletins