Input validation error in Samba - CVE-2012-6150

 

Input validation error in Samba - CVE-2012-6150

Published: December 3, 2013 / Updated: August 3, 2020


Vulnerability identifier: #VU33302
CSH Severity: Low
CVSS v4: 2.1 [CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2012-6150
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote #AU# to read and manipulate data.

The winbind_name_list_to_sid_string_list function in nsswitch/pam_winbind.c in Samba through 4.1.2 handles invalid require_membership_of group names by accepting authentication by any user, which allows remote authenticated users to bypass intended access restrictions in opportunistic circumstances by leveraging an administrator's pam_winbind configuration-file mistake.


Affected software

Samba
Ubuntu
SUSE Linux
samba (Alpine package)
winbind (Ubuntu package)
samba (Ubuntu package)
libpam-winbind (Ubuntu package)

How to mitigate CVE-2012-6150

Install update from vendor's website.

Samba - update to 4.1.3
samba (Alpine package) - update to 3.6.22-r0
winbind (Ubuntu package) - update to 2:3.4.7~dfsg-1ubuntu3.13
samba (Ubuntu package) - addressed in versions 2:3.4.7~dfsg-1ubuntu3.13, 2:3.6.3-2ubuntu2.9, 2:3.6.6-3ubuntu5.3, 2:3.6.9-1ubuntu1.2, 2:3.6.18-1ubuntu3.1
libpam-winbind (Ubuntu package) - addressed in versions 2:3.6.3-2ubuntu2.9, 2:3.6.6-3ubuntu5.3, 2:3.6.9-1ubuntu1.2, 2:3.6.18-1ubuntu3.1

External References

Related Security Bulletins