Buffer overflow in libxi - CVE-2013-1995

 

Buffer overflow in libxi - CVE-2013-1995

Published: June 15, 2013 / Updated: August 3, 2020


Vulnerability identifier: #VU33307
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1995
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

X.org libXi 1.7.1 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to an unexpected sign extension in the XListInputDevices function.


Affected software

libxi
libxi (Alpine package)
libxi6 (Ubuntu package)
Amazon Linux AMI
Ubuntu

How to mitigate CVE-2013-1995

Install update from vendor's website.

libxi - update to 1.7.1.901
libxi (Alpine package) - update to 1.4.5-r1
libxi6 (Ubuntu package) - addressed in versions 2:1.3-3ubuntu0.2, 2:1.6.0-0ubuntu2.1, 2:1.6.1-1ubuntu0.1, 2:1.6.99.1-0ubuntu3.1

External References

Related Security Bulletins