Buffer overflow in libxv - CVE-2013-2066

 

Buffer overflow in libxv - CVE-2013-2066

Published: June 15, 2013 / Updated: August 3, 2020


Vulnerability identifier: #VU33311
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2066
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Buffer overflow in X.org libXv 1.0.7 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XvQueryPortAttributes function.


Affected software

libxv
Amazon Linux AMI
Ubuntu
libxv (Alpine package)
libxv1 (Ubuntu package)

How to mitigate CVE-2013-2066

Install update from vendor's website.

libxv - update to 1.0.8
libxv (Alpine package) - update to 1.0.7-r1
libxv1 (Ubuntu package) - addressed in versions 2:1.0.6-2ubuntu0.1, 2:1.0.7-1ubuntu0.12.10.1, 2:1.0.7-1ubuntu0.13.04.1

External References

Related Security Bulletins