Heap-based buffer overflow in CUPS - CVE-2011-3170

 

Heap-based buffer overflow in CUPS - CVE-2011-3170

Published: August 19, 2011 / Updated: August 3, 2020


Vulnerability identifier: #VU33331
CSH Severity: Medium
CVSS v4: 6.3 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-3170
CWE-ID: CWE-122
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which. A remote attacker can use a crafted stream to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.


Affected software

CUPS
Ubuntu
cups (Alpine package)
libcupsimage2 (Ubuntu package)

How to mitigate CVE-2011-3170

Update to version 1.5.

CUPS - update to 1.5
cups (Alpine package) - update to 1.4.8-r0
libcupsimage2 (Ubuntu package) - addressed in versions 1.3.7-1ubuntu3.13, 1.4.3-1ubuntu1.5, 1.4.4-6ubuntu2.4, 1.4.6-5ubuntu1.4

External References

Related Security Bulletins