Input validation error in libxi - CVE-2013-1984
Published: June 15, 2013 / Updated: August 4, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Multiple integer overflows in X.org libXi 1.7.1 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XGetDeviceControl, (2) XGetFeedbackControl, (3) XGetDeviceDontPropagateList, (4) XGetDeviceMotionEvents, (5) XIGetProperty, (6) XIGetSelectedEvents, (7) XGetDeviceProperties, and (8) XListInputDevices functions.
Affected software
libxi (Alpine package)
libxi6 (Ubuntu package)
Amazon Linux AMI
Ubuntu
How to mitigate CVE-2013-1984
libxi (Alpine package) - update to 1.4.5-r1
libxi6 (Ubuntu package) - addressed in versions 2:1.3-3ubuntu0.2, 2:1.6.0-0ubuntu2.1, 2:1.6.1-1ubuntu0.1, 2:1.6.99.1-0ubuntu3.1
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106913.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00161.html
- http://www.debian.org/security/2013/dsa-2683
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1859-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23