Input validation error in libxvmc - CVE-2013-1990
Published: June 15, 2013 / Updated: August 4, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Multiple integer overflows in X.org libXvMC 1.0.7 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XvMCListSurfaceTypes and (2) XvMCListSubpictureTypes functions.
Affected software
Amazon Linux AMI
Ubuntu
libxvmc (Alpine package)
libxvmc1 (Ubuntu package)
How to mitigate CVE-2013-1990
libxvmc (Alpine package) - update to 1.0.7-r1
libxvmc1 (Ubuntu package) - addressed in versions 2:1.0.6-1ubuntu2.1, 2:1.0.7-1ubuntu1.12.10.1, 2:1.0.7-1ubuntu1.13.04.1
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106766.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00153.html
- http://www.debian.org/security/2013/dsa-2675
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1868-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23
Related Security Bulletins
- Input validation error in xorg.freedesktop libxvmc
- Input validation error in libxvmc (Alpine package)
- Amazon Linux AMI update for libX11, libXcursor, libXfixes, libXi, libXrandr, libXrender, libXres, libXt, libXv, libXvMC, libXxf86dga, libXxf86vm, libdmx, xorg-x11-proto-devel
- Ubuntu update for libxvmc