Input validation error in libxv - CVE-2013-1989

 

Input validation error in libxv - CVE-2013-1989

Published: June 15, 2013 / Updated: August 4, 2020


Vulnerability identifier: #VU33889
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1989
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Multiple integer overflows in X.org libXv 1.0.7 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XvQueryPortAttributes, (2) XvListImageFormats, and (3) XvCreateImage function.


Affected software

libxv
Amazon Linux AMI
Ubuntu
libxv (Alpine package)
libxv1 (Ubuntu package)

How to mitigate CVE-2013-1989

Install update from vendor's website.

libxv - update to 1.0.8
libxv (Alpine package) - update to 1.0.7-r1
libxv1 (Ubuntu package) - addressed in versions 2:1.0.6-2ubuntu0.1, 2:1.0.7-1ubuntu0.12.10.1, 2:1.0.7-1ubuntu0.13.04.1

External References

Related Security Bulletins