Input validation error in libxres - CVE-2013-1988
Published: June 15, 2013 / Updated: August 4, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Multiple integer overflows in X.org libXRes 1.0.6 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XResQueryClients and (2) XResQueryClientResources functions.
Affected software
Amazon Linux AMI
Ubuntu
Slackware Linux
libxres (Alpine package)
libxv (Alpine package)
libxres1 (Ubuntu package)
How to mitigate CVE-2013-1988
libxv (Alpine package) - update to 1.0.7-r1
libxres1 (Ubuntu package) - addressed in versions 2:1.0.5-1ubuntu0.1, 2:1.0.6-1ubuntu0.12.10.1, 2:1.0.6-1ubuntu0.13.04.1
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106880.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00155.html
- http://www.debian.org/security/2013/dsa-2688
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1864-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23