Input validation error in libxrandr - CVE-2013-1986
Published: June 15, 2013 / Updated: August 4, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Multiple integer overflows in X.org libXrandr 1.4.0 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XRRQueryOutputProperty and (2) XRRQueryProviderProperty functions.
Affected software
Amazon Linux AMI
Ubuntu
libxrandr (Alpine package)
libxrandr2 (Ubuntu package)
libxrandr-ltsq2 (Ubuntu package)
How to mitigate CVE-2013-1986
libxrandr (Alpine package) - update to 1.3.2-r1
libxrandr2 (Ubuntu package) - addressed in versions 2:1.3.2-2ubuntu0.2, 2:1.4.0-1ubuntu0.1, 2:1.4.0-1ubuntu1.1
libxrandr-ltsq2 (Ubuntu package) - update to 2:1.4.0-1~precise2
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106857.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00156.html
- http://www.debian.org/security/2013/dsa-2684
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1862-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23
Related Security Bulletins
- Input validation error in xorg.freedesktop libxrandr
- Input validation error in libxrandr (Alpine package)
- Amazon Linux AMI update for libX11, libXcursor, libXfixes, libXi, libXrandr, libXrender, libXres, libXt, libXv, libXvMC, libXxf86dga, libXxf86vm, libdmx, xorg-x11-proto-devel
- Ubuntu update for libxrandr, libxrandr-lts-quantal