Input validation error in libxfixes - CVE-2013-1983
Published: June 15, 2013 / Updated: August 4, 2020
Vulnerability identifier: #VU33896
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1983
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability:
No public exploit available
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Integer overflow in X.org libXfixes 5.0 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the XFixesGetCursorImage function.
Affected software
libxfixes
Amazon Linux AMI
Ubuntu
libxfixes (Alpine package)
libxfixes3 (Ubuntu package)
Amazon Linux AMI
Ubuntu
libxfixes (Alpine package)
libxfixes3 (Ubuntu package)
How to mitigate CVE-2013-1983
Install update from vendor's website.
libxfixes - update to 5.0.1
libxfixes (Alpine package) - update to 5.0-r2
libxfixes3 (Ubuntu package) - addressed in versions 1:5.0-4ubuntu4.1, 1:5.0-4ubuntu5.12.10.1, 1:5.0-4ubuntu5.13.04.1
libxfixes (Alpine package) - update to 5.0-r2
libxfixes3 (Ubuntu package) - addressed in versions 1:5.0-4ubuntu4.1, 1:5.0-4ubuntu5.12.10.1, 1:5.0-4ubuntu5.13.04.1
External References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106794.html
- http://lists.opensuse.org/opensuse-updates/2013-06/msg00144.html
- http://www.debian.org/security/2013/dsa-2676
- http://www.openwall.com/lists/oss-security/2013/05/23/3
- http://www.ubuntu.com/usn/USN-1858-1
- http://www.x.org/wiki/Development/Security/Advisory-2013-05-23
Related Security Bulletins
- Input validation error in xorg.freedesktop libxfixes
- Input validation error in libxfixes (Alpine package)
- Amazon Linux AMI update for libX11, libXcursor, libXfixes, libXi, libXrandr, libXrender, libXres, libXt, libXv, libXvMC, libXxf86dga, libXxf86vm, libdmx, xorg-x11-proto-devel
- Ubuntu update for libxfixes